[GLLUG] Question about tar/Gentoo Linux/emerge

Edward Glowacki glowack2@msu.edu
01 Jul 2002 14:52:25 -0400

On Mon, 2002-07-01 at 13:26, Jason Green wrote:
> Well, I ran out of space while compiling OpenOffice.org using emerge
> (Gentoo's port-based system, very similar to BSD's ports and Debian's
> apt-get).  It downloads the packages, then untar's them, then compiles them.
> So, I changed the temporary directory and the download directory to map to
> my mounted FAT32 drive. 

OpenOffice is a monster to build, even more so than Mozilla... ;) 
Haven't even tried building OpenOffice because of the requirements to
compile.  From the FreeBSD port of OpenOffice:

"To build Openoffice, you should have a lot
of free diskspace (~ 4GB) and you should
be an experienced port builder. This port
has beta quality and does not yet work as
stable as it should."


> When untarring, I get the following errors:
> tar: <filename>: Cannot change ownership to uid 520, gid 526:  Operation not
> permitted
> for all files.  I realize that it's trying to set permissions when it untars
> the file, but can't do it because of the limitations of FAT32 partitions.
> This, in turn, won't allow me to install OpenOffice or other large programs.
> Is there any way to circumvent the permissions that wouldn't cause big
> problems later?  I don't plan on sharing this computer with anyone else, but
> the system will be online almost always.  Any ideas?

Disk is cheap (pricewatch lists 60GB drives at under $75, you can
probably find used drives a lot cheaper)  Get another disk in there as
ext2/ext3/xfs/reiserfs/whatever and you should be OK... =)  Beyond that,
I'm not sure of anything that would really help.

Edward Glowacki				glowack2@msu.edu
GLLUG Peon  				http://www.gllug.org
Imagination is the one weapon in the war against reality.
                -- Jules de Gaultier