[GLLUG] Windows Services for UNIX Issue

Marcus Rademacher radema39 at msu.edu
Fri Jul 25 09:55:56 EDT 2008

Hello everyone,

I'm having a problem accessing an NFS drive on a Linux box from Windows XP
using Windows Services for Unix 3.5. It says it isn't accessible, and I
can't figure out what my issue is.

NFS config info:
exports file

hosts.deny file

hosts.allow file

The NFS drive is accessible from other Linux machines just fine. All
machines are on the same network and use DHCP to get their network info. The
NFS server has no firewall on at this time, and I attempted to connect with
the firewall off on the Windows machine as well. The Windows machine is set
to use NFS through TCP and with a soft mount.

I am able to connect to another nfs partition, with the following in the
exports file: "/share/MD0_DATA/Main",async,no_root_squash)<,async,no_root_squash%29>.
I tried using the same options for both, but that didn't fix my issue.

I also tried removing the hosts.deny and hosts.allow files. I then changed
the exports file to /mnt/nfs/ *(rw,sync,root_squash). I was still not able
to access it. In this state, the other Linux machines were still able to
mount the drive.

So I'm now at a loss of what to try next. I feel like I've removed any issue
on the server configuration side, but I suppose I could be wrong. I don't
know what I can change on the client (windows box) side, however. If anyone
has had experience with Windows SFU, I'd appreciate any help they can give.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.egr.msu.edu/mailman/public/linux-user/attachments/20080725/c20211c9/attachment.html 

More information about the linux-user mailing list