[GLLUG] Wireless Problems at Delta Library

Chick Tower c.e.tower at gmail.com
Thu Nov 18 00:19:52 EST 2010

I sometimes visit the new Delta library by the Lansing Mall to gain 
wireless access to the internet.  When it works, it's fast and 
trouble-free, much better than the Lansing library's wireless.

However, I would guess for the last year or so, about half the time I 
have a problem with the wireless access there.  I can connect just fine, 
do my business for a few minutes, but then the access ceases piece by 
piece.  I know that sounds strange, but here's what happens.  A browser 
like Firefox or Midori works for a few minutes and then begins reporting 
that it can't find whatever web page I'm trying to load because it can't 
find the page's host machine.  If I try to ping www.google.com, 
sometimes it doesn't get any responses to the packages sent, and 
sometimes it says it can't find that URL.  So it appears that sometimes 
I've lost access to the library's DNS server and sometimes not but I 
just can't get out to the internet.  (When everything is working fine, I 
can get replies to my pings, so they aren't blocking that protocol.)

Oddly enough, frequently when I can't view web pages on the internet 
with Firefox and Midori (I haven't tried with Seamonkey or Arora), Dillo 
and links still work, although they eventually lose access to the 
internet as well.  Perhaps the simpler, cruder browsers are ignoring 
something that stops the more advanced browsers, but I don't know what 
that would be.  Tonight I tried to log into Yahoo! Mail with the Midori 
browser (based on WebKit).  I got the logon screen, entered my user name 
and password, but the login never finished.  I switched to Dillo, but 
that got an error message (500, maybe 550, if I recall correctly) that 
made it look like it couldn't handle some component of the website, but 
it did find the login page after Midori had quit resolving properly. 
Then I switched to links and it worked, letting me log in, send an 
e-mail, and then log out.

I asked if any of the IT people were still around, and the guy at the 
library desk said he could help me.  When I told him I was using Linux, 
he said he knew nothing about Linux.  He did say that there are no 
sign-up screens for wireless users (unlike the Lansing library).  He 
also said there's nothing set up to disconnect PCs that have been idle 
for a period of time with wireless access, although they do that for the 
PCs that are available for public use and that connect via cables.  He 
said they don't put any restrictions on wireless access.  He finished by 
saying he didn't think they had many visitors using Linux.  I don't 
recall if I asked about content or any other kind of filtering, but I'm 
not visiting any websites that would run afoul of that, nor am I 
downloading music or running BitTorrent.  I was downloading podcasts 
from NPR, but the problem arose before I started that.

Arch Linux uses dhcpcd rather than dhclient.  I was able to reconnect to 
the internet tonight by terminating the dhcpcd process and reissuing the 
command "dhcpcd wlan0", but it didn't last long that time, either.  I 
don't recall if I've ever tried other distros at the Delta Library, but 
FreeBSD worked the one time I used it.  I don't usually have problems 
like this at other wireless access points.  (Well, our current meeting 
site is problematic for me, too, but I'm not alone in that.)

As I said earlier, it's intermittent.  My visits are usually separated 
by weeks, so I don't know if the problem lasts hours, days, or weeks.  I 
almost always sit in the same spot, facing the same way, with the same 
PC and wireless PCMCIA card.  There are never soft drink cans on the 
table when I'm there, but there is a table lamp on the table.  I turned 
it off tonight before I booted my PC.  Nobody pushed any library carts 
by me tonight.  Some command-line programs that access the internet seem 
to handle the problem better than GUI programs, or at least they 
sometimes resist the problem longer than the GUI programs.

Can any of you think of anything that could cause this kind of behavior? 
  If it's not the library, which claims to offer unrestricted wireless, 
could it be something their internet provider is doing?  This isn't a 
life-or-death situation; I'm just puzzled at such unusual behavior.  I'm 
not going to go there with multiple PCs with different distros or other 
OSes to see if they perform differently, but if people want to meet 
there and compare our results, I'd be willing to do that.


More information about the linux-user mailing list